Mac does not recognize jukebox drives
Posted by Sven Koester on 08 October 2007 15:20
Sometimes, it is difficult to recognize why SCSI drives are not recognized by MAC`s. To avoid confusion, please follow these steps when troubleshooting the PresSTORE jukebox configuration:
  1. In case the jukebox was already configured before, clear the files /usr/local/aw/conf/dev/*.  These are created when setting up the jukebox and might lead a new setup into a wrong direction.
  2. Set up the jukebox again. Check whether all drives are then recognized.
  3. Check the drive availability with the ioreg command by executing: ioreg -l -w 0 > ~/Desktop/iokit.txt This will create a text file named iokit.txt on the Desktop. In this file, jukeboxes shall be visible in the section  "Peripheral Device Type" = 8 and tape drives shall be visible in the section "Peripheral Device Type" = 1.

In case a drive is not recognized by the ioreg utility, PresSTORE will not recognize it either. In this case, a hardware problem exists,
check the SCSI and power cabling. Note that you will have to reboot the Mac afterwards to detect the devices on the SCSI chain.

In case ioreg does show both drives and PresSTORE does not recognize the drives, try rebooting the Mac. The drive then was present at boot time but is no longer present. This effect may be caused by a SCSI reset. See also the following article:

SCSI devices inaccessible ... 

(836 vote(s))
Helpful
Not helpful

Comments (4)
Ben
28 August 2012 4:01
If you have a fibre channel library, then you can rescan the Fibre Channel bus using fibreconfig -r instead of a restart.
Drazen Korda
26 November 2013 11:05
Just to note that this has helped me on two occasions in the past 2 weeks so thank you very much.
Peter G. Sengstock
31 January 2014 23:16
I'd be interested in learning more about this fibreconfig command. I tried it, but it didn't work for me. I had to reset our library again, and I hate having to wait for a service window to get backups running again. I tried the command, but PresSTORE still cannot talk to the library.
Andre Kuehnemund
18 February 2014 11:16
'fibreconfig' is an Apple command. As far as we know it only works with Apple branded FC cards and is intended to be used with Xsans. While this command appears to have worked for some customers and their libraries, it has not for others - probably due to differences in their setups. You would need to contact Apple for more information on how this command can be used.
Post a new comment
 
 
Full Name:
Email:
Comments:
CAPTCHA Verification 
 
Please enter the text you see in the image into the textbox below (we use this to prevent automated submissions).