Knowledgebase: Mac OSX Specific
External Drive Mount Problems on Mac
Posted by Sven Koester on 25 November 2010 12:34
Mac hosts mount external hard disk volumes by their name, so a disk named MyStorage will be mounted at /Volumes/MyStorage and the finder will show the disk named MyStorage. All this happens automatically.

However as any automatic system this may fail:
It may appear that the mount point name already exists in /Volumes when the disk is connected, e.g. because the disk was not properly unmounted. In this case, the disk is still mounted automatically, but at the mount point /Volumes/Mystorage 1.
The finder will not show this, it still refers to the volume by its label and shows MyStorage.

This may have an impact on PresSTORE Backup- or Synchronize plans:
As PresSTORE operates on a given path (and not on a Volume), it may still attempt to backup /Volumes/MyStorage, thus saving an empty folder instead of the external disk.
Synchronizing to an external disk may behave even worse, as the sync will write to /Volumes/MyStorage which is now a folder on the root filesystem, so the root filesystem may be filled by accident.

A practise to avoid that is never adressing the root folder of an external disk but a subfolder there. In case the volume disappears, the folder does the same and the job accessing that folder will come up with an error.

To resolve the failure, simply unmount the disk and remove the leftover folder from previous mount procedures.

This is a feature of OS X - not a bug in Presstore. As such, there is not much we can do to work around it, other than the suggestion to use a subfolder instead of a volume root and to make sure an external volume is mounted properly.
(101 vote(s))
Helpful
Not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments:
CAPTCHA Verification 
 
Please enter the text you see in the image into the textbox below (we use this to prevent automated submissions).