Installation problem on Windows 7 x64
Posted by Sven Koester on 09 December 2009 17:20
In some cases the PresSTORE installation fails on Windows 7 x64 systems with the following symptoms:
- The installation starts a command window that remains for 5 minutes
- Subsequently the PresSTORE Server Manager utility shows up and shows the PresSTORE server is not running
- When attempting to start PresSTORE, a message appears:
   "Error: service did not respond in time."
   or 
   "The service cannot accept control messages at this time"

The reason is that the Windows 32 bit subsystem, WOW64, attempts to load the required system dlls and may require approximately 1-2 minutes to do so (possibly caused by specific TCP/IP dlls). On the other hand, the service controller manager has a timeout of 30 seconds by default and will not wait until the dlls are loaded.

To overcome this, we suggest to enhance the timeout of the service controller manager. To do so, please use regedit and set the following value:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ServicesPipeTimeout = (DWORD) 180000.

This value defines in milliseconds how long the service controller manager will wait before it claims a service to be not responding.
Note that you will need to reboot in order for the change to take effect.


 

(162 vote(s))
Helpful
Not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments:
CAPTCHA Verification 
 
Please enter the text you see in the image into the textbox below (we use this to prevent automated submissions).